<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">



<html xmlns="http://www.w3.org/1999/xhtml">



<head profile="http://gmpg.org/xfn/11">







<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />



	



<title>NASCAR Truck: David Gilliland moves team to national level - Auto Racing Daily | Auto Racing Daily</title>







	<link rel="stylesheet" type="text/css" media="all" href="http://autoracingdaily.com/wp-content/themes/wpnewspaper/style.css" />



	



	<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://autoracingdaily.com/feed/" />	



	<link rel="pingback" href="http://autoracingdaily.com/xmlrpc.php" />







	
<!-- This site is optimized with the Yoast WordPress SEO plugin v1.4.3 - http://yoast.com/wordpress/seo/ -->
<link rel="canonical" href="http://autoracingdaily.com/nascar-truck-david-gilliland-moves-team-to-national-level/" />
<!-- / Yoast WordPress SEO plugin. -->

<link rel="alternate" type="application/rss+xml" title="Auto Racing Daily &raquo; Feed" href="http://autoracingdaily.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Auto Racing Daily &raquo; Comments Feed" href="http://autoracingdaily.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Auto Racing Daily &raquo; NASCAR Truck: David Gilliland moves team to national level Comments Feed" href="http://autoracingdaily.com/nascar-truck-david-gilliland-moves-team-to-national-level/feed/" />
<link rel='stylesheet' id='smooth_slider_headcss-css'  href='http://autoracingdaily.com/wp-content/plugins/smooth-slider/css/skins/default/style.css?ver=2.4' type='text/css' media='all' />
<link rel='stylesheet' id='TwitterHomeTimeline-stylesheet-css'  href='http://autoracingdaily.com/wp-content/plugins/Twitter-Home-Timeline/stylesheet.css?ver=3.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='NextGEN-css'  href='http://autoracingdaily.com/wp-content/plugins/nextgen-gallery/css/nggallery.css?ver=1.0.0' type='text/css' media='screen' />
<link rel='stylesheet' id='thickbox-css'  href='http://autoracingdaily.com/wp-includes/js/thickbox/thickbox.css?ver=20121105' type='text/css' media='all' />
<link rel='stylesheet' id='fancyboxcss-css'  href='http://autoracingdaily.com/wp-content/themes/wpnewspaper/inc/js/fancybox/jquery.fancybox-1.3.4.css?ver=3.5.1' type='text/css' media='all' />
<script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js?ver=3.5.1'></script>
<script type='text/javascript' src='http://autoracingdaily.com/wp-content/plugins/smooth-slider/js/jcycle.js?ver=2.4'></script>
<script type='text/javascript' src='http://autoracingdaily.com/wp-content/plugins/nextgen-gallery/js/jquery.cycle.all.min.js?ver=2.9995'></script>
<script type='text/javascript' src='http://autoracingdaily.com/wp-content/plugins/nextgen-gallery/js/ngg.slideshow.min.js?ver=1.06'></script>
<script type='text/javascript' src='http://autoracingdaily.com/wp-content/themes/wpnewspaper/inc/js/jquery.cycle.all.min.js?ver=3.5.1'></script>
<script type='text/javascript' src='http://autoracingdaily.com/wp-content/themes/wpnewspaper/inc/js/slides.min.jquery.js?ver=3.5.1'></script>
<script type='text/javascript' src='http://autoracingdaily.com/wp-content/themes/wpnewspaper/inc/js/jquery.tools.min.js?ver=3.5.1'></script>
<script type='text/javascript' src='http://autoracingdaily.com/wp-content/themes/wpnewspaper/inc/js/flowplayer/flowplayer-3.2.6.min.js?ver=3.5.1'></script>
<script type='text/javascript' src='http://autoracingdaily.com/wp-content/themes/wpnewspaper/inc/js/superfish-1.4.8.js?ver=3.5.1'></script>
<script type='text/javascript' src='http://apis.google.com/js/plusone.js?ver=3.5.1'></script>
<script type='text/javascript' src='http://autoracingdaily.com/wp-content/themes/wpnewspaper/inc/js/fancybox/jquery.fancybox-1.3.4.pack.js?ver=3.5.1'></script>
<script type='text/javascript' src='http://autoracingdaily.com/wp-content/themes/wpnewspaper/inc/js/fancybox/jquery.mousewheel-3.0.4.pack.js?ver=3.5.1'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://autoracingdaily.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://autoracingdaily.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 3.5.1" />
<link rel='shortlink' href='http://autoracingdaily.com/?p=22084' />

<!-- All in One SEO Pack 1.6.15.3 by Michael Torbert of Semper Fi Web Design[321,426] -->
<meta name="keywords" content="camping world truck series,chris eggleston,david gilliland,dgr-crosley,nascar" />
<link rel="canonical" href="http://autoracingdaily.com/nascar-truck-david-gilliland-moves-team-to-national-level/" />
<!-- /all in one seo pack -->
<!-- <meta name="NextGEN" version="1.9.10" /> -->
<meta property='og:type' content='article' />
<meta property='og:title' content='NASCAR Truck: David Gilliland moves team to national level' />
<meta property='og:url' content='http://autoracingdaily.com/nascar-truck-david-gilliland-moves-team-to-national-level/' />
<meta property='og:description' content='By AMANDA VINCENT Veteran NASCAR driver David Gilliland has merged his race team with CROSLEY Racing Group, forming DGR-CROSLEY. The newly-formed race team purchased the assets of former multi-truck NASCAR Camping World Truck Series race team, Red Horse Racing, and will embark on Truck Series racing, in addition racing late models, in the ARCA Racing Series and the NASCAR K&amp;N Pro Series. The DGR-CROSLEY team will operate in the former Red Horse Racing shop with a technical alliance with Kyle Busch Motorsports. the former David Gilliland Racing team already has a technical relationship with KBM for late model racing.       “There is so much value in joining forces with CROSLEY Sports Group,” Gilliland said, as quoted in a Frontstretch.com article.  “Bo LeMastus and I have been working on this for several months, and we’re both very excited about this new company. Bringing together CROSLEY and Red Horse Racing assets are exactly what DGR needed to take [...]' />
<meta property='og:site_name' content='Auto Racing Daily' />
<meta property='fb:app_id' content='465906110120259' />
<meta property='og:locale' content='en_US' />
<meta property='og:image' content='http://autoracingdaily.com/wp-content/uploads/2018/01/07_nwtsc_eggleston_121015.jpg' />
<link rel='image_src' href='http://autoracingdaily.com/wp-content/uploads/2018/01/07_nwtsc_eggleston_121015.jpg' />
 <style type="text/css">.smooth_slider .sldr_title {
background: none repeat scroll 0 0 #CD1713; width:150px; color: #FFFFFF !important; font:bold 16px/22px 'droid sans',Arial,Helvetica,Sans-serif !important; padding:5px;
}
.smooth_slider .smooth_slideri h2{
margin-top:10px !important;
padding-top:10px !important;
float:left  !important;
width:500px  !important;
}</style>
<link href="http://autoracingdaily.com/wp-content/themes/wpnewspaper/styles/default.css" rel="stylesheet" type="text/css" />

	<script type='text/javascript'>
	(function($) {
		$(document).ready(function() { 
			
			$('a[href=#top]').click(function(){	$('html, body').animate({scrollTop:0}, 'slow');	return false; });
			
			$("a[rel=gab_gallery]").fancybox({
				'transitionIn'		: 'none',
				'transitionOut'		: 'none',
				'titlePosition' 	: 'over',
				'titleFormat'       : function(title, currentArray, currentIndex, currentOpts) {
					return '<span id="fancybox-title-over">' + title /* + ' ('+(currentIndex + 1) + ' / ' + currentArray.length + ')' */ +'</span>';
				}
			});				
				
			$('#featured-slider .fea-slides').cycle({ 
				pauseOnPagerHover: 1,
				prev:   '.fea_prev',
				next:   '.fea_next',
				pauseOnPagerHover: 1,
				fx:     'fade',
				timeout: '5',
				speed: '1',
				pager:  '#featured-nav', 
				pagerAnchorBuilder: function(idx, slide) { 
					// return selector string for existing anchor 
					return '#featured-nav li:eq(' + idx + ') a'; 
				} 
			});

			$('#video-slider .fea-slides').cycle({ 
				pauseOnPagerHover: 1,
				prev:   '.vid_prev',
				next:   '.vid_next',
				pager:  '#vid-nav', 
				fx:     'fade',
				timeout: 0
			});
			
			$('#mid-slider .fea-slides').cycle({ 
				fx:     'fade', 
				timeout: 0,
				prev:   '.media_prev',
				next:   '.media_next',
				pauseOnPagerHover: 1,
				pager:  '#mid-slider-pagination', 
				pagerAnchorBuilder: function(idx, slide) { 
					// return selector string for existing anchor 
					return '#mid-slider-pagination li:eq(' + idx + ') a'; 
				} 
			});					

			$('#slides').slides({
								play: 5000,
				pause: 2500,
				hoverPause: true,
								autoHeight: true
			});
			
			$(".show").fancybox({  'titleShow': 'false','transitionIn': 'fade','transitionOut': 'fade'});
			$(".iframe").fancybox({	'width'	: '75%','height' : '75%','autoScale': false,'transitionIn': 'none','transitionOut': 'none','type': 'iframe'});
			$("ul.tabs").tabs("div.panes > div");

		});
	})(jQuery);
	</script>
<link rel="shortcut icon" href="http://autoracingdaily.com/wp-content/themes/wpnewspaper/inc/admin//images/favicon.ico" /><script type="text/javascript">

 var _gaq = _gaq || [];
 _gaq.push(['_setAccount', 'UA-173387-1']);
 _gaq.push(['_trackPageview']);

 (function() {
   var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
   ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
   var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
 })();

</script>
	



	



		



	



	


	



	<!--[if lte IE 8]>



		<style type="text/css" media="screen">



			#gab_gallery .apple_overlay {border:1px solid #aaa;}



		</style>



	<![endif]-->	



<script>



    $(document).ready(function() { 



 $('.timeline-header').css("display", "none");

	

			setInterval(function() {

 $('a#media_next').click();



		

  }, 5000); // 1500 ms loop







			



	

	});



</script>


<script type="text/javascript">

 var _gaq = _gaq || [];
 _gaq.push(['_setAccount', 'UA-173387-1']);
 _gaq.push(['_trackPageview']);

 (function() {
   var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
   ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
   var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
 })();

</script>
</head>







<body class="single single-post postid-22084 single-format-standard">










<div class="wrapper">



	<div id="masthead">



		<ul class="mastheadnav dropdown">



			


			



				<li class="date">



					<script type="text/javascript">



						<!--



						var mydate=new Date()



						var year=mydate.getYear()



						if (year < 1000)



						year+=1900



						var day=mydate.getDay()



						var month=mydate.getMonth()



						var daym=mydate.getDate()



						if (daym<10)



						daym="0"+daym



						var dayarray=new Array("Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday")



						var montharray=new Array("January","February","March","April","May","June","July","August","September","October","November","December")



						document.write(""+dayarray[day]+", "+montharray[month]+" "+daym+", "+year+"")



						// -->



					</script>



				</li>



				<li><a class="show" href="#sconnected">Login with Facebook Connect</a></li>			



			


		</ul>



		<div class="hide">



			<div id="sconnected"> 



				<div id="gab_share_widget-2" class="widget gab_share_widget"><div class="widgetinner"><h3 class="widgettitle">Share This Post</h3>
<div class="share_firstrow"><span class="gab_twitter_box"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://autoracingdaily.com/?p=22084" data-counturl="http://autoracingdaily.com/nascar-truck-david-gilliland-moves-team-to-national-level/" data-lang="en-US" data-related="anywhereTheJavascriptAPI" data-count="vertical">Tweet</a><script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></span><div id="fb-root"></div>
					<script>(function(d, s, id) {
					var js, fjs = d.getElementsByTagName(s)[0];
					if (d.getElementById(id)) return;
					js = d.createElement(s); js.id = id;
					js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
					fjs.parentNode.insertBefore(js, fjs);
					}(document, 'script', 'facebook-jssdk'));</script>
					
					<div class="fb-like" data-href="http://autoracingdaily.com/nascar-truck-david-gilliland-moves-team-to-national-level/" data-send="false" data-layout="box_count" data-width="65" data-show-faces="false"></div><div class="g-plusone" data-size="tall"></div><div class="clear"></div></div><!-- gab_twitter_box --><a target="_blank" rel="nofollow" class="facebook" href="http://www.facebook.com/share.php?u=http://autoracingdaily.com/?p=22084&t=NASCAR Truck: David Gilliland moves team to national level" title="Share on Facebook ">Facebook</a><a target="_blank" rel="nofollow" class="twitter" href="http://twitter.com/home?status=http://autoracingdaily.com/?p=22084" title="Share on Twitter ">Twitter</a><a target="_blank" rel="nofollow" class="email" href="http://www.freetellafriend.com/tell/?heading=Share+This+Article&bg=1&option=email&url=http://autoracingdaily.com/?p=22084" title="Email a Friend ">Email</a><a target="_blank" rel="nofollow" class="delicious" href="http://del.icio.us/post?url=http://autoracingdaily.com/?p=22084&title=NASCAR Truck: David Gilliland moves team to national level" title="Share on Delicious ">Delicious</a><a target="_blank" rel="nofollow" class="digg" href="http://digg.com/submit?url=http://autoracingdaily.com/?p=22084&title=NASCAR Truck: David Gilliland moves team to national level" title="Share on Digg ">Digg</a><a target="_blank" rel="nofollow" class="google2" href="http://www.google.com/bookmarks/mark?op=add&bkmk=http://autoracingdaily.com/?p=22084&title=NASCAR Truck: David Gilliland moves team to national level" title="Share on Google ">Google</a><a target="_blank" rel="nofollow" class="stumbleupon" href="http://www.stumbleupon.com/submit?url=http://autoracingdaily.com/?p=22084&title=NASCAR Truck: David Gilliland moves team to national level" title="Share on StumbleUpon ">Stumbleupon</a><a target="_blank" rel="nofollow" class="reddit" href="http://reddit.com/submit?url=http://autoracingdaily.com/?p=22084&title=NASCAR Truck: David Gilliland moves team to national level" title="Share on Reddit ">Reddit</a><a target="_blank" rel="nofollow" class="technorati" href="http://technorati.com/faves?sub=favthis&add=http://autoracingdaily.com/?p=22084" title="Share on Technorati ">Technorati</a><a target="_blank" rel="nofollow" class="yahoo" href="http://buzz.yahoo.com/buzz?targetUrl=http://autoracingdaily.com/?p=22084&headline=NASCAR Truck: David Gilliland moves team to national level" title="Share on Yahoo ">Yahoo</a><a target="_blank" rel="nofollow" class="blogger" href="http://www.blogger.com/blog_this.pyra?t&u=http://autoracingdaily.com/?p=22084&n=NASCAR Truck: David Gilliland moves team to national level&pli=1" title="Share on Blogger ">Blogger</a><a target="_blank" rel="nofollow" class="myspace" href="http://www.myspace.com/Modules/PostTo/Pages/?u=http://autoracingdaily.com/?p=22084&t=NASCAR Truck: David Gilliland moves team to national level&c=http://autoracingdaily.com/?p=22084" title="Share on Myspace ">Myspace</a><a target="_blank" rel="nofollow" class="rss" href="http://autoracingdaily.com/nascar-truck-david-gilliland-moves-team-to-national-level/feed/" title="RSS Feed ">RSS</a><div class="clear"></div></div></div>



			</div>



		</div>



		



		<div id="search">



			<form class="gab_search_style1" action="http://autoracingdaily.com">
	<fieldset>
		<input type="text" id="s" name="s" value="Search in site..." onfocus="if(this.value==this.defaultValue)this.value='';" onblur="if(this.value=='')this.value=this.defaultValue;"/>
		<input type="image" class="submit_style1" src="http://autoracingdaily.com/wp-content/themes/wpnewspaper/images/framework/search.png" alt="Search in site..." value="" /> 
	</fieldset>
</form>


		</div><!-- /search -->



		<div class="clear"></div>



		



	</div><!-- /masthead -->







	<div id="header">



		


			<a href="http://autoracingdaily.com/" title="">



				<img src="http://autoracingdaily.com/wp-content/uploads/2012/09/header.jpeg" id="header_banner" alt="Auto Racing Daily" title="Auto Racing Daily"/>



			</a>



		


			







	</div><!-- /header -->







	<div id="mainmenu">



		<ul class="mainnav dropdown">



			


			



				<li class="first"><a href="http://autoracingdaily.com/" title="">Home</a></li>



				



					<li class="cat-item cat-item-2247"><a href="http://autoracingdaily.com/category/monsterenergynascarcup/" title="View all posts filed under Monster Energy NASCAR Cup">Monster Energy NASCAR Cup</a>
</li>
	<li class="cat-item cat-item-3"><a href="http://autoracingdaily.com/category/nascar/" title="View all posts filed under NASCAR">NASCAR</a>
</li>
	<li class="cat-item cat-item-2249"><a href="http://autoracingdaily.com/category/nascarcampingworldtruck/" title="View all posts filed under NASCAR Camping World Truck">NASCAR Camping World Truck</a>
</li>
	<li class="cat-item cat-item-2248"><a href="http://autoracingdaily.com/category/nascar-xfinity/" title="View all posts filed under NASCAR Xfinity">NASCAR Xfinity</a>
</li>
	<li class="cat-item cat-item-1"><a href="http://autoracingdaily.com/category/uncategorized/" title="View all posts filed under Uncategorized">Uncategorized</a>
</li>



				



		</ul>



		<div class="clear"></div>



	</div><!-- /mainmenu -->



	



	<div id="submenu">



		<ul class="subnav dropdown">



			


				<li class="page_item page-item-618"><a href="http://autoracingdaily.com/news/">News</a></li>
<li class="page_item page-item-19198"><a href="http://autoracingdaily.com/racing-odds/"><li class="page_item page-item-19198"><a href="https://mybookie.ag/sportsbook/auto-racing-betting-lines/" title="Racing Odds" target="_blank">Racing Odds</a></li></a></li>
<li class="page_item page-item-20885"><a href="http://autoracingdaily.com/youtube/"><li class="page_item page-item-19198"><a href="http://www.youtube.com/theracingmedia/" title="YouTube" target="_blank">YouTube</a></li></a></li>
<li class="page_item page-item-20894"><a href="http://autoracingdaily.com/contact-us/">Contact Us/Social Media</a></li>
<li class="page_item page-item-21424"><a href="http://autoracingdaily.com/shop-for-nascar-fan-gear-and-collectibles-at-fanatics/"><a href="http://shareasale.com/r.cfm?b=850655&#038;u=678124&#038;m=7124&#038;urllink=&#038;afftrack=">Shop for NASCAR Merchandise</a></a></li>
<li class="page_item page-item-21442"><a href="http://autoracingdaily.com/our-nascar-picks-from-amazon/"><li><a href="https://www.amazon.com/shop/nascar-examiner" title="NASCAR Picks from Amazon" target="_blank">NASCAR Picks from Amazon</a></li></a></li>
<li class="page_item page-item-21447"><a href="http://autoracingdaily.com/nascar-collectibles/"><a href="http://shareasale.com/r.cfm?b=758647&#038;u=678124&#038;m=28250&#038;urllink=&#038;afftrack=">Race-Used NASCAR Collectibles</a></a></li>
<li class="page_item page-item-21448"><a href="http://autoracingdaily.com/buy-race-tickets-2/"><a href="http://shareasale.com/r.cfm?b=716875&#038;u=678124&#038;m=17988&#038;urllink=&#038;afftrack=">Buy Race Tickets</a></a></li>
<li class="page_item page-item-21456"><a href="http://autoracingdaily.com/find-a-hotel-near-the-track/"><a href="http://shareasale.com/r.cfm?b=687632&#038;u=678124&#038;m=57136&#038;urllink=&#038;afftrack=">Find a hotel near the track</a></a></li>
<li class="page_item page-item-21656"><a href="http://autoracingdaily.com/shop-target/"><a href="http://goto.target.com/c/1180654/81938/2092">Shop Target</a></a></li>



				



		</ul>



		<div class="clear"></div>



	</div><!-- /submenu -->



	


	<div id="container">



			<div id="main">

				


					<div id="post-22084" class="post-22084 post type-post status-publish format-standard hentry category-breaking-news category-featured category-nascar category-nascarcampingworldtruck tag-camping-world-truck-series tag-chris-eggleston tag-david-gilliland tag-dgr-crosley tag-nascar entry">

						<h1 class="entry_title">

							NASCAR Truck: David Gilliland moves team to national level
						</h1>

									

						
<div id="attachment_22086" class="wp-caption aligncenter" style="width: 406px"><a href="http://autoracingdaily.com/wp-content/uploads/2018/01/07_nwtsc_eggleston_121015.jpg"><img class="size-full wp-image-22086" alt="Chris Eggleston (photo courtesy of Getty Images for NASCAR)" src="http://autoracingdaily.com/wp-content/uploads/2018/01/07_nwtsc_eggleston_121015.jpg" width="396" height="600" /></a><p class="wp-caption-text">Chris Eggleston (photo courtesy of Getty Images for NASCAR)</p></div>
<p><strong>By AMANDA VINCENT</strong></p>
<p>Veteran NASCAR driver David Gilliland has merged his race team with CROSLEY Racing Group, forming DGR-CROSLEY. The newly-formed race team purchased the assets of former multi-truck NASCAR Camping World Truck Series race team, Red Horse Racing, and will embark on Truck Series racing, in addition racing late models, in the ARCA Racing Series and the NASCAR K&amp;N Pro Series.</p>
<p>The DGR-CROSLEY team will operate in the former Red Horse Racing shop with a technical alliance with Kyle Busch Motorsports. the former David Gilliland Racing team already has a technical relationship with KBM for late model racing.</p>
<!-- Quick Adsense WordPress Plugin: http://quicksense.net/ -->
<div style="float:none;margin:10px 0 10px 0;text-align:center;">
<script type="text/javascript">
google_ad_client = "ca-pub-8201897207053754";
/* Intext Ad */
google_ad_slot = "8120585606";
google_ad_width = 250;
google_ad_height = 250;
</script>
<script type="text/javascript" src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</div>

<p>“There is so much value in joining forces with CROSLEY Sports Group,” Gilliland said, as quoted in a <a href="https://www.frontstretch.com/2018/01/22/newly-formed-dgr-crosley-acquires-assets-of-red-horse-racing/" target="_blank">Frontstretch.com article</a>.  “Bo LeMastus and I have been working on this for several months, and we’re both very excited about this new company. Bringing together CROSLEY and Red Horse Racing assets are exactly what DGR needed to take it to this unique level. It’s been my plan to get into the Truck Series for quite some time. Now, we have a well-designed driver development program to groom drivers in championship caliber equipment as they work their way up through the ranks.”</p>
<p>Chris Eggleston has been named as one of the drivers of the new team’s No. 17 Toyota for a partial Truck Series schedule. Drivers for additional Truck Series races will be announced later.</p><div class="wpInsert wpInsertInPostAd wpInsertMiddle" style="margin: 5px; padding: 0px;float:left;border:1px dotted #AAAAAA;"><script type="text/javascript"><!--
google_ad_client = "ca-pub-8201897207053754";
/* Intext Ad */
google_ad_slot = "8120585606";
google_ad_width = 250;
google_ad_height = 250;
//-->
</script>
<script type="text/javascript"
src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script></div>
<p>“Although DGR-Crosley will be new to the truck side of things from an ownership perspective, I feel very confident that we will be running up front, especially with the new trucks from Red Horse and support from TRD (Toyota Racing Development),” Eggleston said. &#8220;It proves David and his team are committed to their truck program and I’m really looking forward to be a part of it and help make it grow.”</p>
<p>Eggleston competed in the NASCAR K&amp;N Series West last season, finishing the year second in the standings on the strength of four wins, 11 top-fives and 13 top-10 finishes. He was the series champion in 2015. He has competed full-time in the K&amp;N Series West the last three years.</p>
<p>Eggleston also has limited Camping World Truck Series starts, having six-career series starts to is credit, the most recent coming in 2014. His career best Truck Series finish, to date, was an 11th at Martinsville (Va.) Speedway in 2010.</p>
<p>Eggleston’s first Truck Series start this season will come at Charlotte (N.C.) Motor Speedway in May.</p>
<p><em>Follow Auto Racing Daily on Twitter <a href="http://www.twitter.com/autoracingdaily" target="_blank">@AutoRacingDaily</a> or like Auto Racing Daily on Facebook (<a href="http://www.facebook.com/autoracingdailyonline" target="_blank">facebook.com/autoracingdailyonline</a>).</em></p>

<div style="font-size:0px;height:0px;line-height:0px;margin:0;padding:0;clear:both"></div><div class="wpInsert wpInsertInPostAd wpInsertBelow" style="margin: 5px; padding: 0px;"><script type="text/javascript">
google_ad_client = "ca-pub-8201897207053754";
/* Intext Ad */
google_ad_slot = "8120585606";
google_ad_width = 250;
google_ad_height = 250;
</script>
<script type="text/javascript" src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script></div><div class="clear"></div>				
			<div id="gab_share_widget-3" class="widget gab_share_widget"><div class="widgetinner"><h3 class="widgettitle">Share This Post</h3>
<div class="share_firstrow"><span class="gab_twitter_box"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://autoracingdaily.com/?p=22084" data-counturl="http://autoracingdaily.com/nascar-truck-david-gilliland-moves-team-to-national-level/" data-lang="en-US" data-related="anywhereTheJavascriptAPI" data-count="vertical">Tweet</a><script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></span><div id="fb-root"></div>
					<script>(function(d, s, id) {
					var js, fjs = d.getElementsByTagName(s)[0];
					if (d.getElementById(id)) return;
					js = d.createElement(s); js.id = id;
					js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
					fjs.parentNode.insertBefore(js, fjs);
					}(document, 'script', 'facebook-jssdk'));</script>
					
					<div class="fb-like" data-href="http://autoracingdaily.com/nascar-truck-david-gilliland-moves-team-to-national-level/" data-send="false" data-layout="box_count" data-width="65" data-show-faces="false"></div><div class="g-plusone" data-size="tall"></div><div class="clear"></div></div><!-- gab_twitter_box --><a target="_blank" rel="nofollow" class="facebook" href="http://www.facebook.com/share.php?u=http://autoracingdaily.com/?p=22084&t=NASCAR Truck: David Gilliland moves team to national level" title="Share on Facebook ">Facebook</a><a target="_blank" rel="nofollow" class="twitter" href="http://twitter.com/home?status=http://autoracingdaily.com/?p=22084" title="Share on Twitter ">Twitter</a><a target="_blank" rel="nofollow" class="email" href="http://www.freetellafriend.com/tell/?heading=Share+This+Article&bg=1&option=email&url=http://autoracingdaily.com/?p=22084" title="Email a Friend ">Email</a><a target="_blank" rel="nofollow" class="delicious" href="http://del.icio.us/post?url=http://autoracingdaily.com/?p=22084&title=NASCAR Truck: David Gilliland moves team to national level" title="Share on Delicious ">Delicious</a><a target="_blank" rel="nofollow" class="digg" href="http://digg.com/submit?url=http://autoracingdaily.com/?p=22084&title=NASCAR Truck: David Gilliland moves team to national level" title="Share on Digg ">Digg</a><a target="_blank" rel="nofollow" class="google2" href="http://www.google.com/bookmarks/mark?op=add&bkmk=http://autoracingdaily.com/?p=22084&title=NASCAR Truck: David Gilliland moves team to national level" title="Share on Google ">Google</a><a target="_blank" rel="nofollow" class="stumbleupon" href="http://www.stumbleupon.com/submit?url=http://autoracingdaily.com/?p=22084&title=NASCAR Truck: David Gilliland moves team to national level" title="Share on StumbleUpon ">Stumbleupon</a><a target="_blank" rel="nofollow" class="reddit" href="http://reddit.com/submit?url=http://autoracingdaily.com/?p=22084&title=NASCAR Truck: David Gilliland moves team to national level" title="Share on Reddit ">Reddit</a><a target="_blank" rel="nofollow" class="technorati" href="http://technorati.com/faves?sub=favthis&add=http://autoracingdaily.com/?p=22084" title="Share on Technorati ">Technorati</a><a target="_blank" rel="nofollow" class="yahoo" href="http://buzz.yahoo.com/buzz?targetUrl=http://autoracingdaily.com/?p=22084&headline=NASCAR Truck: David Gilliland moves team to national level" title="Share on Yahoo ">Yahoo</a><a target="_blank" rel="nofollow" class="blogger" href="http://www.blogger.com/blog_this.pyra?t&u=http://autoracingdaily.com/?p=22084&n=NASCAR Truck: David Gilliland moves team to national level&pli=1" title="Share on Blogger ">Blogger</a><a target="_blank" rel="nofollow" class="myspace" href="http://www.myspace.com/Modules/PostTo/Pages/?u=http://autoracingdaily.com/?p=22084&t=NASCAR Truck: David Gilliland moves team to national level&c=http://autoracingdaily.com/?p=22084" title="Share on Myspace ">Myspace</a><a target="_blank" rel="nofollow" class="rss" href="http://autoracingdaily.com/nascar-truck-david-gilliland-moves-team-to-national-level/feed/" title="RSS Feed ">RSS</a><div class="clear"></div></div></div>

						

						
							<div class="singlepostmeta">

								<img alt='' src='http://0.gravatar.com/avatar/41b145bb554e9de56df74f17e9700737?s=39&amp;d=http%3A%2F%2F0.gravatar.com%2Favatar%2Fad516503a11cd5ca435acc9bb6523536%3Fs%3D39&amp;r=G' class='avatar avatar-39 photo' height='39' width='39' />
								Posted by  <a href="http://autoracingdaily.com/author/ard2012/" title="Posts by ard2012" rel="author">ard2012</a> 

								
								on January 31, 2018. Filed under <a href="http://autoracingdaily.com/category/breaking-news/" title="View all posts in Breaking News" rel="category tag">Breaking News</a>,<a href="http://autoracingdaily.com/category/featured/" title="View all posts in Featured" rel="category tag">Featured</a>,<a href="http://autoracingdaily.com/category/nascar/" title="View all posts in NASCAR" rel="category tag">NASCAR</a>,<a href="http://autoracingdaily.com/category/nascarcampingworldtruck/" title="View all posts in NASCAR Camping World Truck" rel="category tag">NASCAR Camping World Truck</a>.

								You can follow any responses to this entry through the <a href='http://autoracingdaily.com/nascar-truck-david-gilliland-moves-team-to-national-level/feed/'>RSS 2.0</a>.

								
								You can leave a response or trackback to this entry
									

								<div class="clear"></div>

							</div>	

												



					</div><!-- .entry -->



				
				

				
<div id="comments">
	
	
	
	
									<div id="respond">
				<h3 id="reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/nascar-truck-david-gilliland-moves-team-to-national-level/#respond" style="display:none;">Cancel reply</a></small></h3>
									<p class="must-log-in">You must be <a href="http://autoracingdaily.com/wp-login.php?redirect_to=http%3A%2F%2Fautoracingdaily.com%2Fnascar-truck-david-gilliland-moves-team-to-national-level%2F">logged in</a> to post a comment.</p>												</div><!-- #respond -->
						
	
</div><!-- #comments -->
				

			</div><!-- #main -->

			

			<div id="sidebar">

				<div class="sidebarinner">

	<div class="sidebar_left">

	<div id="gab_custom_widget-2" class="widget gab_custom_widget"><div class="widgetinner"><span class="catname"><a href="http://autoracingdaily.com/category/breaking-news/">Breaking News</a></span>
                <div class="featuredpost">

											<h2 class="posttitle">
							<a href="http://autoracingdaily.com/nascar-xfinity-truck-rookies-test-atlanta-motor-speedway/" rel="bookmark" title="Permalink to NASCAR Xfinity, Truck: rookies test Atlanta Motor Speedway" >NASCAR Xfinity, Truck: rookies test Atlanta Motor Speedway</a>
						</h2>
					<p class="postmeta"><span class="meta_date">January 31, 2018</span><span class="meta_comment"><a href="http://autoracingdaily.com/nascar-xfinity-truck-rookies-test-atlanta-motor-speedway/#respond" title="Comment on NASCAR Xfinity, Truck: rookies test Atlanta Motor Speedway">Comments</a></span><span class="meta_permalink"><a href="http://autoracingdaily.com/nascar-xfinity-truck-rookies-test-atlanta-motor-speedway/" title="Permalink to NASCAR Xfinity, Truck: rookies test Atlanta Motor Speedway" rel="bookmark">Read More</a></span></p>                    
                </div><!-- .featuredpost -->
            
                <div class="featuredpost">

											<h2 class="posttitle">
							<a href="http://autoracingdaily.com/nextgen-motorsports-plans-partial-truck-xfinity-schedules/" rel="bookmark" title="Permalink to NextGen Motorsports plans partial Truck, Xfinity schedules" >NextGen Motorsports plans partial Truck, Xfinity schedules</a>
						</h2>
					<p class="postmeta"><span class="meta_date">January 31, 2018</span><span class="meta_comment"><a href="http://autoracingdaily.com/nextgen-motorsports-plans-partial-truck-xfinity-schedules/#respond" title="Comment on NextGen Motorsports plans partial Truck, Xfinity schedules">Comments</a></span><span class="meta_permalink"><a href="http://autoracingdaily.com/nextgen-motorsports-plans-partial-truck-xfinity-schedules/" title="Permalink to NextGen Motorsports plans partial Truck, Xfinity schedules" rel="bookmark">Read More</a></span></p>                    
                </div><!-- .featuredpost -->
            
                <div class="featuredpost">

											<h2 class="posttitle">
							<a href="http://autoracingdaily.com/nascar-truck-jjl-motorsports-up-program-with-bkr-equipment/" rel="bookmark" title="Permalink to NASCAR Truck: JJL Motorsports steps up program with BKR equipment" >NASCAR Truck: JJL Motorsports steps up program with BKR equipment</a>
						</h2>
					<p class="postmeta"><span class="meta_date">January 31, 2018</span><span class="meta_comment"><a href="http://autoracingdaily.com/nascar-truck-jjl-motorsports-up-program-with-bkr-equipment/#respond" title="Comment on NASCAR Truck: JJL Motorsports steps up program with BKR equipment">Comments</a></span><span class="meta_permalink"><a href="http://autoracingdaily.com/nascar-truck-jjl-motorsports-up-program-with-bkr-equipment/" title="Permalink to NASCAR Truck: JJL Motorsports steps up program with BKR equipment" rel="bookmark">Read More</a></span></p>                    
                </div><!-- .featuredpost -->
            
                <div class="featuredpost">

											<h2 class="posttitle">
							<a href="http://autoracingdaily.com/nascar-truck-david-gilliland-moves-team-to-national-level/" rel="bookmark" title="Permalink to NASCAR Truck: David Gilliland moves team to national level" >NASCAR Truck: David Gilliland moves team to national level</a>
						</h2>
					<p class="postmeta"><span class="meta_date">January 31, 2018</span><span class="meta_comment"><a href="http://autoracingdaily.com/nascar-truck-david-gilliland-moves-team-to-national-level/#respond" title="Comment on NASCAR Truck: David Gilliland moves team to national level">Comments</a></span><span class="meta_permalink"><a href="http://autoracingdaily.com/nascar-truck-david-gilliland-moves-team-to-national-level/" title="Permalink to NASCAR Truck: David Gilliland moves team to national level" rel="bookmark">Read More</a></span></p>                    
                </div><!-- .featuredpost -->
            
                <div class="featuredpost lastpost">

											<h2 class="posttitle">
							<a href="http://autoracingdaily.com/nascar-truck-ben-kennedy-moves-into-administrative-role/" rel="bookmark" title="Permalink to NASCAR Truck: Ben Kennedy moves into administrative role" >NASCAR Truck: Ben Kennedy moves into administrative role</a>
						</h2>
					<p class="postmeta"><span class="meta_date">January 30, 2018</span><span class="meta_comment"><a href="http://autoracingdaily.com/nascar-truck-ben-kennedy-moves-into-administrative-role/#respond" title="Comment on NASCAR Truck: Ben Kennedy moves into administrative role">Comments</a></span><span class="meta_permalink"><a href="http://autoracingdaily.com/nascar-truck-ben-kennedy-moves-into-administrative-role/" title="Permalink to NASCAR Truck: Ben Kennedy moves into administrative role" rel="bookmark">Read More</a></span></p>                    
                </div><!-- .featuredpost -->
                </div></div>
<div id="text-5" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><img src="http://autoracingdaily.com/wp-content/themes/wpnewspaper/images/tweet.png" style="display:inline;">
<span class="red_b">Latest Tweets</span></div>
		</div></div>
<ul class="lcp_catlist"><li><h2 class="cat_main_class"><a href="http://autoracingdaily.com/nascar-xfinity-truck-rookies-test-atlanta-motor-speedway/" title="NASCAR Xfinity, Truck: rookies test Atlanta Motor Speedway">NASCAR Xfinity, Truck: rookies test Atlanta Motor Speedway</a></h2>By AMANDA VINCENT
Atlanta Motor Speedway hosted a two-day NASCAR rookie test Monday and Tuesday, ahead ... <a href="http://autoracingdaily.com/nascar-xfinity-truck-rookies-test-atlanta-motor-speedway/" class="post_r_m"  >Read More</a></li><li><h2 class="cat_main_class"><a href="http://autoracingdaily.com/nextgen-motorsports-plans-partial-truck-xfinity-schedules/" title="NextGen Motorsports plans partial Truck, Xfinity schedules">NextGen Motorsports plans partial Truck, Xfinity schedules</a></h2>By AMANDA VINCENT
NextGen Motorsports began NASCAR competition last year in the K&amp;N Pro Series East. ... <a href="http://autoracingdaily.com/nextgen-motorsports-plans-partial-truck-xfinity-schedules/" class="post_r_m"  >Read More</a></li><li><h2 class="cat_main_class"><a href="http://autoracingdaily.com/nascar-truck-jjl-motorsports-up-program-with-bkr-equipment/" title="NASCAR Truck: JJL Motorsports steps up program with BKR equipment">NASCAR Truck: JJL Motorsports steps up program with BKR equipment</a></h2>By AMANDA VINCENT
JJL Motorsports purchased assets of the shuttered Brad Keselowski Racing operation and plans ... <a href="http://autoracingdaily.com/nascar-truck-jjl-motorsports-up-program-with-bkr-equipment/" class="post_r_m"  >Read More</a></li><li class = current ><h2 class="cat_main_class"><a href="http://autoracingdaily.com/nascar-truck-david-gilliland-moves-team-to-national-level/" title="NASCAR Truck: David Gilliland moves team to national level">NASCAR Truck: David Gilliland moves team to national level</a></h2>By AMANDA VINCENT
Veteran NASCAR driver David Gilliland has merged his race team with CROSLEY Racing ... <a href="http://autoracingdaily.com/nascar-truck-david-gilliland-moves-team-to-national-level/" class="post_r_m"  >Read More</a></li><li><h2 class="cat_main_class"><a href="http://autoracingdaily.com/nascar-truck-ben-kennedy-moves-into-administrative-role/" title="NASCAR Truck: Ben Kennedy moves into administrative role">NASCAR Truck: Ben Kennedy moves into administrative role</a></h2>By AMANDA VINCENT
Ben Kennedy has shifted gears in his NASCAR career, as he was announced ... <a href="http://autoracingdaily.com/nascar-truck-ben-kennedy-moves-into-administrative-role/" class="post_r_m"  >Read More</a></li><li><h2 class="cat_main_class"><a href="http://autoracingdaily.com/nascar-cup-jeffrey-earnhardt-keeps-family-daytona-500-streak-alive/" title="NASCAR Cup: Jeffrey Earnhardt keeps family Daytona 500 streak alive">NASCAR Cup: Jeffrey Earnhardt keeps family Daytona 500 streak alive</a></h2>By AMANDA VINCENT
After retiring from full-time competition in the Monster Energy NASCAR Cup Series at ... <a href="http://autoracingdaily.com/nascar-cup-jeffrey-earnhardt-keeps-family-daytona-500-streak-alive/" class="post_r_m"  >Read More</a></li><li><h2 class="cat_main_class"><a href="http://autoracingdaily.com/nascar-xfinity-dale-earnhardt-jr-to-race-richmond/" title="NASCAR Xfinity: Dale Earnhardt Jr. to race Richmond">NASCAR Xfinity: Dale Earnhardt Jr. to race Richmond</a></h2>By AMANDA VINCENT
Dale Earnhardt Jr. announced via Twitter on Sunday that he would be behind ... <a href="http://autoracingdaily.com/nascar-xfinity-dale-earnhardt-jr-to-race-richmond/" class="post_r_m"  >Read More</a></li><li><h2 class="cat_main_class"><a href="http://autoracingdaily.com/nascar-presence-in-rolex-24-at-daytona/" title="NASCAR presence in Rolex 24 at Daytona">NASCAR presence in Rolex 24 at Daytona</a></h2>By AMANDA VINCENT
Saturday/Sunday’s Rolex 24 at Daytona IMSA event on the Daytona (Fla.) International Speedway ... <a href="http://autoracingdaily.com/nascar-presence-in-rolex-24-at-daytona/" class="post_r_m"  >Read More</a></li><li><h2 class="cat_main_class"><a href="http://autoracingdaily.com/nascar-xfinity-roush-fenway-racing-announces-driver-schedule-for-no-60-team/" title="NASCAR Xfinity: Roush Fenway Racing announces driver schedule for No. 60 team">NASCAR Xfinity: Roush Fenway Racing announces driver schedule for No. 60 team</a></h2>By AMANDA VINCENT
Ford developmental drivers Austin Cindric, Chase Briscoe and Ty Majeski are sharing the ... <a href="http://autoracingdaily.com/nascar-xfinity-roush-fenway-racing-announces-driver-schedule-for-no-60-team/" class="post_r_m"  >Read More</a></li><li><h2 class="cat_main_class"><a href="http://autoracingdaily.com/nascar-cup-derrick-finley-moved-to-front-row-motorsports-no-34-team/" title="NASCAR Cup: Derrick Finley moved to Front Row Motorsports' No. 34 team">NASCAR Cup: Derrick Finley moved to Front Row Motorsports&#8217; No. 34 team</a></h2>By AMANDA VINCENT
Derrick Finley will be Michael McDowell’s crew chief on the No. 34 Front ... <a href="http://autoracingdaily.com/nascar-cup-derrick-finley-moved-to-front-row-motorsports-no-34-team/" class="post_r_m"  >Read More</a></li></ul><div id="text-3" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><!-- Automotive Newcar Widget -->

            <link rel="stylesheet" href="http://affddl.automotive.com/widgets/car/1/car.css"/>

            <div class="sim-car-widget">

            <span class="sim-car-head"></span>

            <span class="sim-car-form" data-datasetid="4" data-hostname="http://www.automotive.com"></span>

            <span class="sim-car-link">Powered by <a rel="nofollow" href="http://www.automotive.com" title="Automotive.com">Automotive.com</a></span>

            </div>

            <script src="http://ajax.googleapis.com/ajax/libs/jquery/1.6.4/jquery.js"></script>

            <script src="http://affddl.automotive.com/widgets/car/1/car.js"></script>

            <!-- End of Automotive Newcar Widget -->
<br />

                                <b>Find <a href="http://usautoinsurancecompany.com/auto-insurance/">auto insurance rates</a> near you!</b>

                                <br /></div>
		</div></div>

	</div><!-- .sidebar_left -->

	

	<div class="sidebar_right">

			<div class="widget">

		<div class="widgetinner">

		

			
				
		</div><!-- .widgetinner -->

	</div><!-- .widget --><script type="text/javascript"><!--
google_ad_client = "ca-pub-8201897207053754";
/* Right Side Skyscraper */
google_ad_slot = "0724388342";
google_ad_width = 120;
google_ad_height = 600;
//-->
</script>
<script type="text/javascript" src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
	</div><!-- .sidebar_right -->

	<div class="clear"></div>

</div><!-- .sidebarinner -->
			</div><!-- #Sidebar -->	

			<div class="clear"></div>

	</div><!-- #Container -->



</div><!-- wrapper -->





<div id="footer">

	

	<div class="clear"></div>



	

	

	<div class="clear"></div>

			

	<div id="footer_meta">

		<p class="footer-left-text">	

			
				&copy; 2018, <a href="#top" title="Auto Racing Daily" rel="home"><strong>&uarr;</strong> Auto Racing Daily</a>

			
		</p>

		

		<p class="footer-right-text">

			<a rel="nofollow" href="http://autoracingdaily.com/wp-login.php">Log in</a>-
					<a href="http://autoracingdaily.com/wp-admin/edit.php">Posts</a> - 

					<a href="http://autoracingdaily.com/wp-admin/post-new.php">Add New</a>

				 - 

			
			<a href="http://wordpress.org/" title="Semantic Personal Publishing Platform" rel="generator">Powered by WordPress</a> - 

			Designed and Developed by <a href="http://www.BandPsoftware.com/" title="B and P software">B and P Software</a> 

			
<script type="text/javascript">tb_pathToImage = "http://autoracingdaily.com/wp-includes/js/thickbox/loadingAnimation.gif";tb_closeImage = "http://autoracingdaily.com/wp-includes/js/thickbox/tb-close.png";</script>
<script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/autoracingdaily.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif","closeImage":"http:\/\/autoracingdaily.com\/wp-includes\/js\/thickbox\/tb-close.png"};
/* ]]> */
</script>
<script type='text/javascript' src='http://autoracingdaily.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<div id="fb-root"></div>
<script type="text/javascript">
  window.fbAsyncInit = function() {
    FB.init({"appId":"465906110120259","channelUrl":"http:\/\/autoracingdaily.com\/?sfc-channel-file=1","status":true,"cookie":true,"xfbml":true,"oauth":true});
      };
  (function(d){
       var js, id = 'facebook-jssdk'; if (d.getElementById(id)) {return;}
       js = d.createElement('script'); js.id = id; js.async = true;
       js.src = "//connect.facebook.net/en_US/all.js";
       d.getElementsByTagName('head')[0].appendChild(js);
   }(document));     
</script>

		</p>

		<div class="clear"></div>

	</div>

</div><!-- /footer -->	



</body>

</html>