<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">



<html xmlns="http://www.w3.org/1999/xhtml">



<head profile="http://gmpg.org/xfn/11">







<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />



	



<title>NASCAR Truck: Dover International Speedway entry list | Auto Racing Daily</title>







	<link rel="stylesheet" type="text/css" media="all" href="http://autoracingdaily.com/wp-content/themes/wpnewspaper/style.css" />



	



	<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://autoracingdaily.com/feed/" />	



	<link rel="pingback" href="http://autoracingdaily.com/xmlrpc.php" />







	
<!-- All in One SEO Pack 2.4.5.1 by Michael Torbert of Semper Fi Web Design[321,421] -->
<meta name="keywords"  content="campingworld truck series,dover international speedway,jegs 200,nascar" />

<link rel="canonical" href="http://autoracingdaily.com/nascar-truck-dover-international-speedway-entry-list/" />
<!-- /all in one seo pack -->

<!-- This site is optimized with the Yoast SEO plugin v6.3.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://autoracingdaily.com/nascar-truck-dover-international-speedway-entry-list/" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/autoracingdaily.com\/","name":"Auto Racing Daily","potentialAction":{"@type":"SearchAction","target":"http:\/\/autoracingdaily.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Auto Racing Daily &raquo; Feed" href="http://autoracingdaily.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Auto Racing Daily &raquo; Comments Feed" href="http://autoracingdaily.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Auto Racing Daily &raquo; NASCAR Truck: Dover International Speedway entry list Comments Feed" href="http://autoracingdaily.com/nascar-truck-dover-international-speedway-entry-list/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/autoracingdaily.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='TwitterHomeTimeline-stylesheet-css'  href='http://autoracingdaily.com/wp-content/plugins/Twitter-Home-Timeline/stylesheet.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='wpos-slick-style-css'  href='http://autoracingdaily.com/wp-content/plugins/wp-responsive-recent-post-slider/assets/css/slick.css?ver=1.3.4' type='text/css' media='all' />
<link rel='stylesheet' id='wppsac-public-style-css'  href='http://autoracingdaily.com/wp-content/plugins/wp-responsive-recent-post-slider/assets/css/recent-post-style.css?ver=1.3.4' type='text/css' media='all' />
<link rel='stylesheet' id='fancyboxcss-css'  href='http://autoracingdaily.com/wp-content/themes/wpnewspaper/inc/js/fancybox/jquery.fancybox-1.3.4.css?ver=4.9.5' type='text/css' media='all' />
<script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='http://autoracingdaily.com/wp-content/themes/wpnewspaper/inc/js/jquery.cycle.all.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='http://autoracingdaily.com/wp-content/themes/wpnewspaper/inc/js/slides.min.jquery.js?ver=4.9.5'></script>
<script type='text/javascript' src='http://autoracingdaily.com/wp-content/themes/wpnewspaper/inc/js/jquery.tools.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='http://autoracingdaily.com/wp-content/themes/wpnewspaper/inc/js/flowplayer/flowplayer-3.2.6.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='http://autoracingdaily.com/wp-content/themes/wpnewspaper/inc/js/superfish-1.4.8.js?ver=4.9.5'></script>
<script type='text/javascript' src='http://apis.google.com/js/plusone.js?ver=4.9.5'></script>
<script type='text/javascript' src='http://autoracingdaily.com/wp-content/themes/wpnewspaper/inc/js/fancybox/jquery.fancybox-1.3.4.pack.js?ver=4.9.5'></script>
<script type='text/javascript' src='http://autoracingdaily.com/wp-content/themes/wpnewspaper/inc/js/fancybox/jquery.mousewheel-3.0.4.pack.js?ver=4.9.5'></script>
<link rel='https://api.w.org/' href='http://autoracingdaily.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://autoracingdaily.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://autoracingdaily.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.5" />
<link rel='shortlink' href='http://autoracingdaily.com/?p=23415' />
<link rel="alternate" type="application/json+oembed" href="http://autoracingdaily.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fautoracingdaily.com%2Fnascar-truck-dover-international-speedway-entry-list%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://autoracingdaily.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fautoracingdaily.com%2Fnascar-truck-dover-international-speedway-entry-list%2F&#038;format=xml" />
<meta property='og:type' content='article' />
<meta property='og:title' content='NASCAR Truck: Dover International Speedway entry list' />
<meta property='og:url' content='http://autoracingdaily.com/nascar-truck-dover-international-speedway-entry-list/' />
<meta property='og:description' content='By AMANDA VINCENT After a break of longer than a month, the NASCAR Camping World Truck Series returns to action Friday evening with the running of the JEGS 200 at Dover (Del.) International Speedway. The Dover race is the fifth race of the 23-race 2018 CampingWorld Truck Series season. Johnny Sauter was the winner of last year&#039;s Dover race. He is one of 34 drivers on the entry list for the JEGS 200, so barring any withdrawals, two of the entered teams/drivers will find themselves on the outside looking in after Friday afternoon&#039;s qualifying session.       Qualifying is scheduled for 1:05 p.m. ET Friday, with the race to follow at 5 p.m. Both qualifying and the race will be shown live on FOX Sports 1. Below, is the entry list for Friday&#039;s JEGS 200 at Dover International Speedway:' />
<meta property='og:site_name' content='Auto Racing Daily' />
<meta property='fb:app_id' content='465906110120259' />
<meta property='og:locale' content='en_US' />
<meta property='og:image' content='http://autoracingdaily.com/wp-content/uploads/2018/05/dover1_jegs_200_race_logo.jpg' />
<link rel='image_src' href='http://autoracingdaily.com/wp-content/uploads/2018/05/dover1_jegs_200_race_logo.jpg' />
<meta property='og:image' content='http://autoracingdaily.com/wp-content/uploads/2018/05/T1805_PREENTNUM.jpg' />
<link rel='image_src' href='http://autoracingdaily.com/wp-content/uploads/2018/05/T1805_PREENTNUM.jpg' />
 <style type="text/css">.smooth_slider .sldr_title {
background: none repeat scroll 0 0 #CD1713; width:150px; color: #FFFFFF !important; font:bold 16px/22px 'droid sans',Arial,Helvetica,Sans-serif !important; padding:5px;
}
.smooth_slider .smooth_slideri h2{
margin-top:10px !important;
padding-top:10px !important;
float:left  !important;
width:500px  !important;
}</style>
<!-- <meta name="NextGEN" version="2.2.50" /> -->
<style data-context="foundation-flickity-css">/*! Flickity v2.0.2
http://flickity.metafizzy.co
---------------------------------------------- */.flickity-enabled{position:relative}.flickity-enabled:focus{outline:0}.flickity-viewport{overflow:hidden;position:relative;height:100%}.flickity-slider{position:absolute;width:100%;height:100%}.flickity-enabled.is-draggable{-webkit-tap-highlight-color:transparent;tap-highlight-color:transparent;-webkit-user-select:none;-moz-user-select:none;-ms-user-select:none;user-select:none}.flickity-enabled.is-draggable .flickity-viewport{cursor:move;cursor:-webkit-grab;cursor:grab}.flickity-enabled.is-draggable .flickity-viewport.is-pointer-down{cursor:-webkit-grabbing;cursor:grabbing}.flickity-prev-next-button{position:absolute;top:50%;width:44px;height:44px;border:none;border-radius:50%;background:#fff;background:hsla(0,0%,100%,.75);cursor:pointer;-webkit-transform:translateY(-50%);transform:translateY(-50%)}.flickity-prev-next-button:hover{background:#fff}.flickity-prev-next-button:focus{outline:0;box-shadow:0 0 0 5px #09F}.flickity-prev-next-button:active{opacity:.6}.flickity-prev-next-button.previous{left:10px}.flickity-prev-next-button.next{right:10px}.flickity-rtl .flickity-prev-next-button.previous{left:auto;right:10px}.flickity-rtl .flickity-prev-next-button.next{right:auto;left:10px}.flickity-prev-next-button:disabled{opacity:.3;cursor:auto}.flickity-prev-next-button svg{position:absolute;left:20%;top:20%;width:60%;height:60%}.flickity-prev-next-button .arrow{fill:#333}.flickity-page-dots{position:absolute;width:100%;bottom:-25px;padding:0;margin:0;list-style:none;text-align:center;line-height:1}.flickity-rtl .flickity-page-dots{direction:rtl}.flickity-page-dots .dot{display:inline-block;width:10px;height:10px;margin:0 8px;background:#333;border-radius:50%;opacity:.25;cursor:pointer}.flickity-page-dots .dot.is-selected{opacity:1}</style><style data-context="foundation-slideout-css">.slideout-menu{position:fixed;left:0;top:0;bottom:0;right:auto;z-index:0;width:256px;overflow-y:auto;-webkit-overflow-scrolling:touch;display:none}.slideout-menu.pushit-right{left:auto;right:0}.slideout-panel{position:relative;z-index:1;will-change:transform}.slideout-open,.slideout-open .slideout-panel,.slideout-open body{overflow:hidden}.slideout-open .slideout-menu{display:block}.pushit{display:none}</style><link href="http://autoracingdaily.com/wp-content/themes/wpnewspaper/styles/sans-purple.css" rel="stylesheet" type="text/css" />

	<script type='text/javascript'>
	(function($) {
		$(document).ready(function() { 
			
			$('a[href=#top]').click(function(){	$('html, body').animate({scrollTop:0}, 'slow');	return false; });
			
			$("a[rel=gab_gallery]").fancybox({
				'transitionIn'		: 'none',
				'transitionOut'		: 'none',
				'titlePosition' 	: 'over',
				'titleFormat'       : function(title, currentArray, currentIndex, currentOpts) {
					return '<span id="fancybox-title-over">' + title /* + ' ('+(currentIndex + 1) + ' / ' + currentArray.length + ')' */ +'</span>';
				}
			});				
				
			$('#featured-slider .fea-slides').cycle({ 
				pauseOnPagerHover: 1,
				prev:   '.fea_prev',
				next:   '.fea_next',
				pauseOnPagerHover: 1,
				fx:     'fade',
				timeout: '5',
				speed: '1',
				pager:  '#featured-nav', 
				pagerAnchorBuilder: function(idx, slide) { 
					// return selector string for existing anchor 
					return '#featured-nav li:eq(' + idx + ') a'; 
				} 
			});

			$('#video-slider .fea-slides').cycle({ 
				pauseOnPagerHover: 1,
				prev:   '.vid_prev',
				next:   '.vid_next',
				pager:  '#vid-nav', 
				fx:     'fade',
				timeout: 0
			});
			
			$('#mid-slider .fea-slides').cycle({ 
				fx:     'fade', 
				timeout: 0,
				prev:   '.media_prev',
				next:   '.media_next',
				pauseOnPagerHover: 1,
				pager:  '#mid-slider-pagination', 
				pagerAnchorBuilder: function(idx, slide) { 
					// return selector string for existing anchor 
					return '#mid-slider-pagination li:eq(' + idx + ') a'; 
				} 
			});					

			$('#slides').slides({
								play: 5000,
				pause: 2500,
				hoverPause: true,
								autoHeight: true
			});
			
			$(".show").fancybox({  'titleShow': 'false','transitionIn': 'fade','transitionOut': 'fade'});
			$(".iframe").fancybox({	'width'	: '75%','height' : '75%','autoScale': false,'transitionIn': 'none','transitionOut': 'none','type': 'iframe'});
			$("ul.tabs").tabs("div.panes > div");

		});
	})(jQuery);
	</script>
<link rel="shortcut icon" href="http://autoracingdaily.com/wp-content/themes/wpnewspaper/inc/admin//images/favicon.ico" /><script type="text/javascript">

 var _gaq = _gaq || [];
 _gaq.push(['_setAccount', 'UA-173387-1']);
 _gaq.push(['_trackPageview']);

 (function() {
   var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
   ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
   var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
 })();

</script>
<style>.ios7.web-app-mode.has-fixed header{ background-color: rgba(3,122,221,.88);}</style>	



	



		



	



	


	



	<!--[if lte IE 8]>



		<style type="text/css" media="screen">



			#gab_gallery .apple_overlay {border:1px solid #aaa;}



		</style>



	<![endif]-->	



<script>



    $(document).ready(function() { 



 $('.timeline-header').css("display", "none");

	

			setInterval(function() {

 $('a#media_next').click();



		

  }, 5000); // 1500 ms loop







			



	

	});



</script>


<script type="text/javascript">

 var _gaq = _gaq || [];
 _gaq.push(['_setAccount', 'UA-173387-1']);
 _gaq.push(['_trackPageview']);

 (function() {
   var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
   ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
   var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
 })();

</script>
</head>







<body class="post-template-default single single-post postid-23415 single-format-standard">










<div class="wrapper">



	<div id="masthead">



		<ul class="mastheadnav dropdown">



			


			



				<li class="date">



					<script type="text/javascript">



						<!--



						var mydate=new Date()



						var year=mydate.getYear()



						if (year < 1000)



						year+=1900



						var day=mydate.getDay()



						var month=mydate.getMonth()



						var daym=mydate.getDate()



						if (daym<10)



						daym="0"+daym



						var dayarray=new Array("Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday")



						var montharray=new Array("January","February","March","April","May","June","July","August","September","October","November","December")



						document.write(""+dayarray[day]+", "+montharray[month]+" "+daym+", "+year+"")



						// -->



					</script>



				</li>



				<li><a class="show" href="#sconnected">Login with Facebook Connect</a></li>			



			


		</ul>



		<div class="hide">



			<div id="sconnected"> 



				<div id="gab_share_widget-2" class="widget gab_share_widget"><div class="widgetinner"><h3 class="widgettitle">Share This Post</h3>
<div class="share_firstrow"><span class="gab_twitter_box"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://autoracingdaily.com/?p=23415" data-counturl="http://autoracingdaily.com/nascar-truck-dover-international-speedway-entry-list/" data-lang="en-US" data-related="anywhereTheJavascriptAPI" data-count="vertical">Tweet</a><script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></span><div id="fb-root"></div>
					<script>(function(d, s, id) {
					var js, fjs = d.getElementsByTagName(s)[0];
					if (d.getElementById(id)) return;
					js = d.createElement(s); js.id = id;
					js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
					fjs.parentNode.insertBefore(js, fjs);
					}(document, 'script', 'facebook-jssdk'));</script>
					
					<div class="fb-like" data-href="http://autoracingdaily.com/nascar-truck-dover-international-speedway-entry-list/" data-send="false" data-layout="box_count" data-width="65" data-show-faces="false"></div><div class="g-plusone" data-size="tall"></div><div class="clear"></div></div><!-- gab_twitter_box --><a target="_blank" rel="nofollow" class="facebook" href="http://www.facebook.com/share.php?u=http://autoracingdaily.com/?p=23415&t=NASCAR Truck: Dover International Speedway entry list" title="Share on Facebook ">Facebook</a><a target="_blank" rel="nofollow" class="twitter" href="http://twitter.com/home?status=http://autoracingdaily.com/?p=23415" title="Share on Twitter ">Twitter</a><a target="_blank" rel="nofollow" class="email" href="http://www.freetellafriend.com/tell/?heading=Share+This+Article&bg=1&option=email&url=http://autoracingdaily.com/?p=23415" title="Email a Friend ">Email</a><a target="_blank" rel="nofollow" class="delicious" href="http://del.icio.us/post?url=http://autoracingdaily.com/?p=23415&title=NASCAR Truck: Dover International Speedway entry list" title="Share on Delicious ">Delicious</a><a target="_blank" rel="nofollow" class="digg" href="http://digg.com/submit?url=http://autoracingdaily.com/?p=23415&title=NASCAR Truck: Dover International Speedway entry list" title="Share on Digg ">Digg</a><a target="_blank" rel="nofollow" class="google2" href="http://www.google.com/bookmarks/mark?op=add&bkmk=http://autoracingdaily.com/?p=23415&title=NASCAR Truck: Dover International Speedway entry list" title="Share on Google ">Google</a><a target="_blank" rel="nofollow" class="stumbleupon" href="http://www.stumbleupon.com/submit?url=http://autoracingdaily.com/?p=23415&title=NASCAR Truck: Dover International Speedway entry list" title="Share on StumbleUpon ">Stumbleupon</a><a target="_blank" rel="nofollow" class="reddit" href="http://reddit.com/submit?url=http://autoracingdaily.com/?p=23415&title=NASCAR Truck: Dover International Speedway entry list" title="Share on Reddit ">Reddit</a><a target="_blank" rel="nofollow" class="technorati" href="http://technorati.com/faves?sub=favthis&add=http://autoracingdaily.com/?p=23415" title="Share on Technorati ">Technorati</a><a target="_blank" rel="nofollow" class="yahoo" href="http://buzz.yahoo.com/buzz?targetUrl=http://autoracingdaily.com/?p=23415&headline=NASCAR Truck: Dover International Speedway entry list" title="Share on Yahoo ">Yahoo</a><a target="_blank" rel="nofollow" class="blogger" href="http://www.blogger.com/blog_this.pyra?t&u=http://autoracingdaily.com/?p=23415&n=NASCAR Truck: Dover International Speedway entry list&pli=1" title="Share on Blogger ">Blogger</a><a target="_blank" rel="nofollow" class="myspace" href="http://www.myspace.com/Modules/PostTo/Pages/?u=http://autoracingdaily.com/?p=23415&t=NASCAR Truck: Dover International Speedway entry list&c=http://autoracingdaily.com/?p=23415" title="Share on Myspace ">Myspace</a><a target="_blank" rel="nofollow" class="rss" href="http://autoracingdaily.com/nascar-truck-dover-international-speedway-entry-list/feed/" title="RSS Feed ">RSS</a><div class="clear"></div></div></div>



			</div>



		</div>



		



		<div id="search">



			<form class="gab_search_style1" action="http://autoracingdaily.com">
	<fieldset>
		<input type="text" id="s" name="s" value="Search in site..." onfocus="if(this.value==this.defaultValue)this.value='';" onblur="if(this.value=='')this.value=this.defaultValue;"/>
		<input type="image" class="submit_style1" src="http://autoracingdaily.com/wp-content/themes/wpnewspaper/images/framework/search.png" alt="Search in site..." value="" /> 
	</fieldset>
</form>


		</div><!-- /search -->



		<div class="clear"></div>



		



	</div><!-- /masthead -->







	<div id="header">



		


			<a href="http://autoracingdaily.com/" title="">



				<img src="http://autoracingdaily.com/wp-content/uploads/2012/09/header.jpeg" id="header_banner" alt="Auto Racing Daily" title="Auto Racing Daily"/>



			</a>



		


			







	</div><!-- /header -->







	<div id="mainmenu">



		<ul class="mainnav dropdown">



			


			



				<li class="first"><a href="http://autoracingdaily.com/" title="">Home</a></li>



				



					<li class="cat-item cat-item-2247"><a href="http://autoracingdaily.com/category/monsterenergynascarcup/" >Monster Energy NASCAR Cup</a>
</li>
	<li class="cat-item cat-item-3"><a href="http://autoracingdaily.com/category/nascar/" >NASCAR</a>
</li>
	<li class="cat-item cat-item-2249"><a href="http://autoracingdaily.com/category/nascarcampingworldtruck/" >NASCAR Camping World Truck</a>
</li>
	<li class="cat-item cat-item-2248"><a href="http://autoracingdaily.com/category/nascar-xfinity/" >NASCAR Xfinity</a>
</li>
	<li class="cat-item cat-item-1"><a href="http://autoracingdaily.com/category/uncategorized/" >Uncategorized</a>
</li>



				



		</ul>



		<div class="clear"></div>



	</div><!-- /mainmenu -->



	



	<div id="submenu">



		<ul class="subnav dropdown">



			


				<li class="page_item page-item-618"><a href="http://autoracingdaily.com/news/">News</a></li>
<li class="page_item page-item-19198"><a href="http://autoracingdaily.com/racing-odds/"><li class="page_item page-item-19198"><a href="https://mybookie.ag/sportsbook/auto-racing-betting-lines/" title="Racing Odds" target="_blank">Racing Odds</a></li></a></li>
<li class="page_item page-item-20885"><a href="http://autoracingdaily.com/youtube/"><li class="page_item page-item-19198"><a href="http://www.youtube.com/theracingmedia/" title="YouTube" target="_blank">YouTube</a></li></a></li>
<li class="page_item page-item-20894"><a href="http://autoracingdaily.com/contact-us/">Contact Us/Social Media</a></li>
<li class="page_item page-item-21424"><a href="http://autoracingdaily.com/shop-for-nascar-fan-gear-and-collectibles-at-fanatics/"><a href="http://shareasale.com/r.cfm?b=850655&#038;u=678124&#038;m=7124&#038;urllink=&#038;afftrack=">Shop for NASCAR Merchandise</a></a></li>
<li class="page_item page-item-21442"><a href="http://autoracingdaily.com/our-nascar-picks-from-amazon/"><li><a href="https://www.amazon.com/shop/nascar-examiner" title="NASCAR Picks from Amazon" target="_blank">NASCAR Picks from Amazon</a></li></a></li>
<li class="page_item page-item-21447"><a href="http://autoracingdaily.com/nascar-collectibles/"><a href="http://shareasale.com/r.cfm?b=758647&#038;u=678124&#038;m=28250&#038;urllink=&#038;afftrack=">Race-Used NASCAR Collectibles</a></a></li>
<li class="page_item page-item-21448"><a href="http://autoracingdaily.com/buy-race-tickets-2/"><a href="http://shareasale.com/r.cfm?b=716875&#038;u=678124&#038;m=17988&#038;urllink=&#038;afftrack=">Buy Race Tickets</a></a></li>
<li class="page_item page-item-21456"><a href="http://autoracingdaily.com/find-a-hotel-near-the-track/"><a href="http://shareasale.com/r.cfm?b=687632&#038;u=678124&#038;m=57136&#038;urllink=&#038;afftrack=">Find a hotel near the track</a></a></li>
<li class="page_item page-item-21656"><a href="http://autoracingdaily.com/shop-target/"><a href="http://goto.target.com/c/1180654/81938/2092">Shop Target</a></a></li>



				



		</ul>



		<div class="clear"></div>



	</div><!-- /submenu -->



	


	<div id="container">



			<div id="main">

				


					<div id="post-23415" class="entry post-23415 post type-post status-publish format-standard has-post-thumbnail hentry category-breaking-news category-featured category-nascar category-nascarcampingworldtruck tag-campingworld-truck-series tag-dover-international-speedway tag-jegs-200 tag-nascar">

						<h1 class="entry_title">

							NASCAR Truck: Dover International Speedway entry list
						</h1>

									

						

	<div id="slides" style="width:485px;">
		<a href="#" class="next"><img src="http://autoracingdaily.com/wp-content/themes/wpnewspaper/images/framework/arrow-next.png" alt=""></a>	
		<a href="#" class="prev"><img src="http://autoracingdaily.com/wp-content/themes/wpnewspaper/images/framework/arrow-prev.png" alt=""></a>
		
		<div class="slides_container" style="width:485px;">
			<a href="http://autoracingdaily.com/wp-content/uploads/2018/05/T1805_PREENTNUM.jpg" title="" rel="gab_gallery"><img style="width:479px;display:block;" src="http://autoracingdaily.com/wp-content/themes/wpnewspaper/timthumb.php?src=http%3A%2F%2Fautoracingdaily.com%2Fwp-content%2Fuploads%2F2018%2F05%2FT1805_PREENTNUM.jpg&amp;q=90&amp;w=479&amp;zc=1" width="479" alt="" /></a><a href="http://autoracingdaily.com/wp-content/uploads/2018/05/dover1_jegs_200_race_logo.jpg" title="" rel="gab_gallery"><img style="width:479px;display:block;" src="http://autoracingdaily.com/wp-content/themes/wpnewspaper/timthumb.php?src=http%3A%2F%2Fautoracingdaily.com%2Fwp-content%2Fuploads%2F2018%2F05%2Fdover1_jegs_200_race_logo.jpg&amp;q=90&amp;w=479&amp;zc=1" width="479" alt="" /></a>		</div>

		<div class="clear"></div>
	</div>
	
	<div class="clear"></div>
<p><strong><img class="aligncenter size-full wp-image-23417" src="http://autoracingdaily.com/wp-content/uploads/2018/05/dover1_jegs_200_race_logo.jpg" alt="" width="500" height="282" srcset="http://autoracingdaily.com/wp-content/uploads/2018/05/dover1_jegs_200_race_logo.jpg 500w, http://autoracingdaily.com/wp-content/uploads/2018/05/dover1_jegs_200_race_logo-300x169.jpg 300w, http://autoracingdaily.com/wp-content/uploads/2018/05/dover1_jegs_200_race_logo-390x220.jpg 390w" sizes="(max-width: 500px) 100vw, 500px" />By AMANDA VINCENT</strong></p>
<p>After a break of longer than a month, the NASCAR Camping World Truck Series returns to action Friday evening with the running of the JEGS 200 at Dover (Del.) International Speedway. The Dover race is the fifth race of the 23-race 2018 CampingWorld Truck Series season.</p>
<p>Johnny Sauter was the winner of last year&#8217;s Dover race. He is one of 34 drivers on the entry list for the JEGS 200, so barring any withdrawals, two of the entered teams/drivers will find themselves on the outside looking in after Friday afternoon&#8217;s qualifying session.</p>
<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div style="float:none;margin:10px 0 10px 0;text-align:center;">
<script type="text/javascript">
google_ad_client = "ca-pub-8201897207053754";
/* Intext Ad */
google_ad_slot = "8120585606";
google_ad_width = 250;
google_ad_height = 250;
</script>
<script type="text/javascript" src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</div>

<p>Qualifying is scheduled for 1:05 p.m. ET Friday, with the race to follow at 5 p.m. Both qualifying and the race will be shown live on FOX Sports 1.</p>
<p>Below, is the entry list for Friday&#8217;s JEGS 200 at Dover International Speedway:</p>
<p><img class="aligncenter size-full wp-image-23416" src="http://autoracingdaily.com/wp-content/uploads/2018/05/T1805_PREENTNUM.jpg" alt="" width="700" height="906" srcset="http://autoracingdaily.com/wp-content/uploads/2018/05/T1805_PREENTNUM.jpg 700w, http://autoracingdaily.com/wp-content/uploads/2018/05/T1805_PREENTNUM-232x300.jpg 232w, http://autoracingdaily.com/wp-content/uploads/2018/05/T1805_PREENTNUM-300x388.jpg 300w, http://autoracingdaily.com/wp-content/uploads/2018/05/T1805_PREENTNUM-390x505.jpg 390w" sizes="(max-width: 700px) 100vw, 700px" /></p>

<div style="font-size:0px;height:0px;line-height:0px;margin:0;padding:0;clear:both"></div><div class="clear"></div>				
			<div id="gab_share_widget-3" class="widget gab_share_widget"><div class="widgetinner"><h3 class="widgettitle">Share This Post</h3>
<div class="share_firstrow"><span class="gab_twitter_box"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://autoracingdaily.com/?p=23415" data-counturl="http://autoracingdaily.com/nascar-truck-dover-international-speedway-entry-list/" data-lang="en-US" data-related="anywhereTheJavascriptAPI" data-count="vertical">Tweet</a><script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></span><div id="fb-root"></div>
					<script>(function(d, s, id) {
					var js, fjs = d.getElementsByTagName(s)[0];
					if (d.getElementById(id)) return;
					js = d.createElement(s); js.id = id;
					js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
					fjs.parentNode.insertBefore(js, fjs);
					}(document, 'script', 'facebook-jssdk'));</script>
					
					<div class="fb-like" data-href="http://autoracingdaily.com/nascar-truck-dover-international-speedway-entry-list/" data-send="false" data-layout="box_count" data-width="65" data-show-faces="false"></div><div class="g-plusone" data-size="tall"></div><div class="clear"></div></div><!-- gab_twitter_box --><a target="_blank" rel="nofollow" class="facebook" href="http://www.facebook.com/share.php?u=http://autoracingdaily.com/?p=23415&t=NASCAR Truck: Dover International Speedway entry list" title="Share on Facebook ">Facebook</a><a target="_blank" rel="nofollow" class="twitter" href="http://twitter.com/home?status=http://autoracingdaily.com/?p=23415" title="Share on Twitter ">Twitter</a><a target="_blank" rel="nofollow" class="email" href="http://www.freetellafriend.com/tell/?heading=Share+This+Article&bg=1&option=email&url=http://autoracingdaily.com/?p=23415" title="Email a Friend ">Email</a><a target="_blank" rel="nofollow" class="delicious" href="http://del.icio.us/post?url=http://autoracingdaily.com/?p=23415&title=NASCAR Truck: Dover International Speedway entry list" title="Share on Delicious ">Delicious</a><a target="_blank" rel="nofollow" class="digg" href="http://digg.com/submit?url=http://autoracingdaily.com/?p=23415&title=NASCAR Truck: Dover International Speedway entry list" title="Share on Digg ">Digg</a><a target="_blank" rel="nofollow" class="google2" href="http://www.google.com/bookmarks/mark?op=add&bkmk=http://autoracingdaily.com/?p=23415&title=NASCAR Truck: Dover International Speedway entry list" title="Share on Google ">Google</a><a target="_blank" rel="nofollow" class="stumbleupon" href="http://www.stumbleupon.com/submit?url=http://autoracingdaily.com/?p=23415&title=NASCAR Truck: Dover International Speedway entry list" title="Share on StumbleUpon ">Stumbleupon</a><a target="_blank" rel="nofollow" class="reddit" href="http://reddit.com/submit?url=http://autoracingdaily.com/?p=23415&title=NASCAR Truck: Dover International Speedway entry list" title="Share on Reddit ">Reddit</a><a target="_blank" rel="nofollow" class="technorati" href="http://technorati.com/faves?sub=favthis&add=http://autoracingdaily.com/?p=23415" title="Share on Technorati ">Technorati</a><a target="_blank" rel="nofollow" class="yahoo" href="http://buzz.yahoo.com/buzz?targetUrl=http://autoracingdaily.com/?p=23415&headline=NASCAR Truck: Dover International Speedway entry list" title="Share on Yahoo ">Yahoo</a><a target="_blank" rel="nofollow" class="blogger" href="http://www.blogger.com/blog_this.pyra?t&u=http://autoracingdaily.com/?p=23415&n=NASCAR Truck: Dover International Speedway entry list&pli=1" title="Share on Blogger ">Blogger</a><a target="_blank" rel="nofollow" class="myspace" href="http://www.myspace.com/Modules/PostTo/Pages/?u=http://autoracingdaily.com/?p=23415&t=NASCAR Truck: Dover International Speedway entry list&c=http://autoracingdaily.com/?p=23415" title="Share on Myspace ">Myspace</a><a target="_blank" rel="nofollow" class="rss" href="http://autoracingdaily.com/nascar-truck-dover-international-speedway-entry-list/feed/" title="RSS Feed ">RSS</a><div class="clear"></div></div></div>

						

						
							<div class="singlepostmeta">

								<img alt='' src='http://1.gravatar.com/avatar/41b145bb554e9de56df74f17e9700737?s=39&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/41b145bb554e9de56df74f17e9700737?s=78&#038;d=mm&#038;r=g 2x' class='avatar avatar-39 photo' height='39' width='39' />
								Posted by  <a href="http://autoracingdaily.com/author/ard2012/" title="Posts by ard2012" rel="author">ard2012</a> 

								
								on May 3, 2018. Filed under <a href="http://autoracingdaily.com/category/breaking-news/" rel="category tag">Breaking News</a>,<a href="http://autoracingdaily.com/category/featured/" rel="category tag">Featured</a>,<a href="http://autoracingdaily.com/category/nascar/" rel="category tag">NASCAR</a>,<a href="http://autoracingdaily.com/category/nascarcampingworldtruck/" rel="category tag">NASCAR Camping World Truck</a>.

								You can follow any responses to this entry through the <a href="http://autoracingdaily.com/nascar-truck-dover-international-speedway-entry-list/feed/">RSS 2.0</a>.

								
								You can leave a response or trackback to this entry
									

								<div class="clear"></div>

							</div>	

												



					</div><!-- .entry -->



				
				

				
<div id="comments">
	
	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/nascar-truck-dover-international-speedway-entry-list/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="http://autoracingdaily.com/wp-login.php?redirect_to=http%3A%2F%2Fautoracingdaily.com%2Fnascar-truck-dover-international-speedway-entry-list%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	
	
</div><!-- #comments -->
				

			</div><!-- #main -->

			

			<div id="sidebar">

				<div class="sidebarinner">

	<div class="sidebar_left">

	<div id="gab_custom_widget-2" class="widget gab_custom_widget"><div class="widgetinner"><span class="catname"><a href="http://autoracingdaily.com/category/breaking-news/">Breaking News</a></span>
                <div class="featuredpost">

											<h2 class="posttitle">
							<a href="http://autoracingdaily.com/nascar-truck-dover-international-speedway-entry-list/" rel="bookmark" title="Permalink to NASCAR Truck: Dover International Speedway entry list" >NASCAR Truck: Dover International Speedway entry list</a>
						</h2>
					<p class="postmeta"><span class="meta_date">May 3, 2018</span><span class="meta_comment"><a href="http://autoracingdaily.com/nascar-truck-dover-international-speedway-entry-list/#respond">Comments</a></span><span class="meta_permalink"><a href="http://autoracingdaily.com/nascar-truck-dover-international-speedway-entry-list/" title="Permalink to NASCAR Truck: Dover International Speedway entry list" rel="bookmark">Read More</a></span></p>                    
                </div><!-- .featuredpost -->
            
                <div class="featuredpost">

											<h2 class="posttitle">
							<a href="http://autoracingdaily.com/nascar-xfinity-johnny-sauter-reportedly-spencer-gallaghers-replacement-dover/" rel="bookmark" title="Permalink to NASCAR Xfinity: Johnny Sauter reportedly Spencer Gallagher&#8217;s replacement at Dover" >NASCAR Xfinity: Johnny Sauter reportedly Spencer Gallagher&#8217;s replacement at Dover</a>
						</h2>
					<p class="postmeta"><span class="meta_date">May 3, 2018</span><span class="meta_comment"><a href="http://autoracingdaily.com/nascar-xfinity-johnny-sauter-reportedly-spencer-gallaghers-replacement-dover/#respond">Comments</a></span><span class="meta_permalink"><a href="http://autoracingdaily.com/nascar-xfinity-johnny-sauter-reportedly-spencer-gallaghers-replacement-dover/" title="Permalink to NASCAR Xfinity: Johnny Sauter reportedly Spencer Gallagher&#8217;s replacement at Dover" rel="bookmark">Read More</a></span></p>                    
                </div><!-- .featuredpost -->
            
                <div class="featuredpost">

											<h2 class="posttitle">
							<a href="http://autoracingdaily.com/nascar-schedule-weather-outlook-dover-international-speedway/" rel="bookmark" title="Permalink to NASCAR schedule, weather outlook for Dover International Speedway" >NASCAR schedule, weather outlook for Dover International Speedway</a>
						</h2>
					<p class="postmeta"><span class="meta_date">May 3, 2018</span><span class="meta_comment"><a href="http://autoracingdaily.com/nascar-schedule-weather-outlook-dover-international-speedway/#respond">Comments</a></span><span class="meta_permalink"><a href="http://autoracingdaily.com/nascar-schedule-weather-outlook-dover-international-speedway/" title="Permalink to NASCAR schedule, weather outlook for Dover International Speedway" rel="bookmark">Read More</a></span></p>                    
                </div><!-- .featuredpost -->
            
                <div class="featuredpost">

											<h2 class="posttitle">
							<a href="http://autoracingdaily.com/nascar-cup-starcom-racing-fields-second-car-dover/" rel="bookmark" title="Permalink to NASCAR Cup: StarCom Racing fields second car at Dover" >NASCAR Cup: StarCom Racing fields second car at Dover</a>
						</h2>
					<p class="postmeta"><span class="meta_date">May 3, 2018</span><span class="meta_comment"><a href="http://autoracingdaily.com/nascar-cup-starcom-racing-fields-second-car-dover/#respond">Comments</a></span><span class="meta_permalink"><a href="http://autoracingdaily.com/nascar-cup-starcom-racing-fields-second-car-dover/" title="Permalink to NASCAR Cup: StarCom Racing fields second car at Dover" rel="bookmark">Read More</a></span></p>                    
                </div><!-- .featuredpost -->
            
                <div class="featuredpost lastpost">

											<h2 class="posttitle">
							<a href="http://autoracingdaily.com/nascar-cup-roval-tire-test-resumes-charlotte-motor-speedway/" rel="bookmark" title="Permalink to NASCAR Cup: &#8216;roval&#8217; tire test resumes at Charlotte Motor Speedway" >NASCAR Cup: &#8216;roval&#8217; tire test resumes at Charlotte Motor Speedway</a>
						</h2>
					<p class="postmeta"><span class="meta_date">May 3, 2018</span><span class="meta_comment"><a href="http://autoracingdaily.com/nascar-cup-roval-tire-test-resumes-charlotte-motor-speedway/#respond">Comments</a></span><span class="meta_permalink"><a href="http://autoracingdaily.com/nascar-cup-roval-tire-test-resumes-charlotte-motor-speedway/" title="Permalink to NASCAR Cup: &#8216;roval&#8217; tire test resumes at Charlotte Motor Speedway" rel="bookmark">Read More</a></span></p>                    
                </div><!-- .featuredpost -->
                </div></div>
<div id="text-5" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><img src="http://autoracingdaily.com/wp-content/themes/wpnewspaper/images/tweet.png" style="display:inline;">
<span class="red_b">Latest Tweets</span></div>
		</div></div>
[catlist categorypage="yes" id="-85" excerpt="yes" title_tag="h2" title_class="cat_main_class" posts_morelink_class="post_r_m" thumbnail_class="image_thumb_s"   thumbnail=yes  thumbnail_size=50,50 numberposts=10 posts_morelink="Read More" excerpt_size=15]<div id="text-3" class="widget widget_text"><div class="widgetinner">			<div class="textwidget"><!-- Automotive Newcar Widget -->

            <link rel="stylesheet" href="http://affddl.automotive.com/widgets/car/1/car.css"/>

            <div class="sim-car-widget">

            <span class="sim-car-head"></span>

            <span class="sim-car-form" data-datasetid="4" data-hostname="http://www.automotive.com"></span>

            <span class="sim-car-link">Powered by <a rel="nofollow" href="http://www.automotive.com" title="Automotive.com">Automotive.com</a></span>

            </div>

            <script src="http://ajax.googleapis.com/ajax/libs/jquery/1.6.4/jquery.js"></script>

            <script src="http://affddl.automotive.com/widgets/car/1/car.js"></script>

            <!-- End of Automotive Newcar Widget -->
<br />

                                <b>Find <a href="http://usautoinsurancecompany.com/auto-insurance/">auto insurance rates</a> near you!</b>

                                <br /></div>
		</div></div>

	</div><!-- .sidebar_left -->

	

	<div class="sidebar_right">

			<div class="widget">

		<div class="widgetinner">

		

			
				
		</div><!-- .widgetinner -->

	</div><!-- .widget --><script type="text/javascript"><!--
google_ad_client = "ca-pub-8201897207053754";
/* Right Side Skyscraper */
google_ad_slot = "0724388342";
google_ad_width = 120;
google_ad_height = 600;
//-->
</script>
<script type="text/javascript" src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
	</div><!-- .sidebar_right -->

	<div class="clear"></div>

</div><!-- .sidebarinner -->
			</div><!-- #Sidebar -->	

			<div class="clear"></div>

	</div><!-- #Container -->



</div><!-- wrapper -->





<div id="footer">

	

	<div class="clear"></div>



	

	

	<div class="clear"></div>

			

	<div id="footer_meta">

		<p class="footer-left-text">	

			
				&copy; 2018, <a href="#top" title="Auto Racing Daily" rel="home"><strong>&uarr;</strong> Auto Racing Daily</a>

			
		</p>

		

		<p class="footer-right-text">

			<a rel="nofollow" href="http://autoracingdaily.com/wp-login.php">Log in</a>-
					<a href="http://autoracingdaily.com/wp-admin/edit.php">Posts</a> - 

					<a href="http://autoracingdaily.com/wp-admin/post-new.php">Add New</a>

				 - 

			
			<a href="http://wordpress.org/" title="Semantic Personal Publishing Platform" rel="generator">Powered by WordPress</a> - 

			Designed and Developed by <a href="http://www.BandPsoftware.com/" title="B and P software">B and P Software</a> 

			<!-- ngg_resource_manager_marker --><script type='text/javascript' src='http://autoracingdaily.com/wp-includes/js/wp-embed.min.js?ver=4.9.5'></script>
<!-- Powered by WPtouch: 4.3.26 --><div id="fb-root"></div>
<script type="text/javascript">
  window.fbAsyncInit = function() {
    FB.init({"appId":"465906110120259","channelUrl":"http:\/\/autoracingdaily.com\/?sfc-channel-file=1","status":true,"cookie":true,"xfbml":true,"oauth":true});
      };
  (function(d){
       var js, id = 'facebook-jssdk'; if (d.getElementById(id)) {return;}
       js = d.createElement('script'); js.id = id; js.async = true;
       js.src = "//connect.facebook.net/en_US/all.js";
       d.getElementsByTagName('head')[0].appendChild(js);
   }(document));     
</script>

		</p>

		<div class="clear"></div>

	</div>

</div><!-- /footer -->	



</body>

</html>